查看: 78|回复: 1

这一步编译未通过,是什么问题?

[复制链接]
新浪微博达人勋 QT4CN  未实名认证
论坛徽章:
20
python徽章
日期:2013-05-09 13:21:43数据陷阱解读徽章
日期:2015-08-13 15:21:45R研习者中级
日期:2015-08-20 14:51:11Hadoop研习者中级
日期:2015-08-27 11:53:16Hadoop研习者初级
日期:2016-09-22 11:23:54spark徽章
日期:2016-10-27 10:48:50比特币徽章
日期:2017-09-28 17:18:05机器学习徽章
日期:2018-05-17 15:59:36计算徽章
日期:2018-05-24 16:11:20抽样调查徽章
日期:2015-08-13 10:58:43Oracle研习者初级
日期:2015-07-16 10:46:51nosql徽章
日期:2013-05-09 17:05:06
发表于 2018-5-27 21:43 | 显示全部楼层 |阅读模式
  1. Run catkin_make on the specific package
  2. >> catkin_make -D CATKIN_WHITELIST_PACKAGES="chapter6_tutorials

-- Could not find the required component 'dynamixel_msgs'. The following CMake error indicates that you either need to install the package with the same name or change your environment so that it can be found.
CMake Error at /opt/ros/indigo/share/catkin/cmake/catkinConfig.cmake:83 (find_package):
  Could not find a package configuration file provided by "dynamixel_msgs"
  with any of the following names:


    dynamixel_msgsConfig.cmake
    dynamixel_msgs-config.cmake


  Add the installation prefix of "dynamixel_msgs" to CMAKE_PREFIX_PATH or set
  "dynamixel_msgs_DIR" to a directory containing one of the above files.  If
  "dynamixel_msgs" provides a separate development package or SDK, be sure it
  has been installed.
Call Stack (most recent call first):
  Learning_ROS_for_Robotics_Programming_2nd_edition-hydro-devel/chapter4_tutorials/CMakeLists.txt:7 (find_package)




-- Configuring incomplete, errors occurred!
See also "/home/yury/ros_ws/build/CMakeFiles/CMakeOutput.log".
See also "/home/yury/ros_ws/build/CMakeFiles/CMakeError.log".
make: *** [cmake_check_build_system] Error 1
Invoking "make cmake_check_build_system" failed



回复

使用道具 举报

论坛徽章:
0
发表于 2018-5-31 14:05 | 显示全部楼层

Anytimes your systems says it cannot find a package, it either means you have not installed the package or it is not in your ROS_PACKAGE_PATH (which is set by default when you correctly build your workspace with all packages inside the src folder). 


you probably just want to install it: sudo apt-get install ros-indigo-dynamixel_msgs

回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册 新浪微博登陆

本版积分规则

 

GMT+8, 2018-7-22 03:12 , Processed in 0.114224 second(s), 32 queries .